jump to navigation

Pentagrama! 0.1.1 marzo 11, 2009

Posted by Calabaza in Noticias.
Tags: , ,
4 comments

Pentagrama! es una utilidad gráfica cuyo objetivo es asistir a los usuarios en la creación de hojas pentagramadas en GNU/Linux.

Pentagrama! es simplemente una interfaz. El verdadero trabajo lo realiza Lilypond. Por lo tanto, todo el crédito le corresponde a los desarrolladores de este gran sistema de creación de partituras.

Características de la versión 0.1.1:

* Se agregó la posibilidad de generar pentagramas agrupados. Lo cual permite crear hojas para piano o múltiples instrumentos/voces.
* Mejoras en el código fuente.
* Se agregó el icono para el programa en formato png y svg.
* Se incluye una página man (en inglés).
* Se actualizó la documentación.

Perspectivas para las próximas versiones:

* Tablaturas (instrumentos de 4, 5 y 6 cuerdas).
* Pentagramas para rítmica.
* Pentagramas para percusión.
* Opción para combinar todos estos tipos de pentagramas entre sí (ej: pentagrama + rítmica, pentagrama + tablatura, etc).
* Internacionalización (i18n).

Capturas:

Pentagrama! ventana principal

Pentagrama! ventana principal

Pentagramas agrupados:

Pentagramas agrupados

Pentagramas agrupados

Requerimientos:

lilypond (>= 2.6) aunque podría funcionar con versiones anteriores.
python (>= 2.4)
pygtk (>= 2.2)

Descarga:

pentagrama-0.1.1.tar.gz

md5sum: 670264390a0487ce62bb14c0ac368f09

Anuncios

Pentagrama! 0.1.0 agosto 17, 2008

Posted by Calabaza in Noticias.
Tags: ,
8 comments

Pentagrama! es una utilidad gráfica cuyo objetivo es asistir a los usuarios en la creación de hojas pentagramadas en GNU/Linux.

Pentagrama! es simplemente una interfaz. El verdadero trabajo lo realiza Lilypond. Por lo tanto, todo el crédito le corresponde a los desarrolladores de este gran sistema de creación de partituras.

Escrito por el autor de este blog, la primera versión se presenta en forma de código fuente.

Capturas:

Ventana principal

Pentragrama! principal

Configuración

Pentagrama! configuración

Requerimientos:

lilypond (>= 2.6) aunque podría funcionar con versiones anteriores.
python (>= 2.4)
pygtk (>= 2.2)

Tareas pendientes:

* Permitir la configuración del espaciado vertical entre pentagramas.
* Opción para añadir claves.
* Opción para añadir tablatura.
* Internacionalización (i18n).
* Paquetes para Debian y/o Ubuntu.

Descarga:

pentagrama-0.1.0.tar.gz

md5sum:
31356e2e08afbf8ff759a5d3a92aa3ef